Difference between revisions of "Manually Installing FreeSpace 2 Open"

From FreeSpace Wiki
Jump to: navigation, search
(System Requirements: -Added SOME data, better then nothing.)
Line 9: Line 9:
  
 
===System Requirements===
 
===System Requirements===
 
+
While the original FreeSpace 2 has rather low system requirments, such as a Pentium 200MHz, 32 MB RAM (64 recommended), and a 3D accelerator (Direct3D, Glide) required, FreeSpace 2 Open has slightly higher requirments. However, any computer from the early 2000s should be able to play this, though toggling all the modern graphical eye candy will require a more modern computer.
  
 
== FreeSpace Open Installer ==
 
== FreeSpace Open Installer ==

Revision as of 06:39, 15 July 2007

CURRENTLY COLLATING INFORMATION FOR THIS PAGE

Fractux 10:22, 13 April 2007 (CDT)

FOR NOW, GO TO: Getting Started(Main)



Before you Begin

System Requirements

While the original FreeSpace 2 has rather low system requirments, such as a Pentium 200MHz, 32 MB RAM (64 recommended), and a 3D accelerator (Direct3D, Glide) required, FreeSpace 2 Open has slightly higher requirments. However, any computer from the early 2000s should be able to play this, though toggling all the modern graphical eye candy will require a more modern computer.

FreeSpace Open Installer

You can use the excellent installer by Turey, that should give you a baseline of everything you need to play.


There are two versions of the installer that you can download:


This Installer is known to work on Windows, Linux (tested on Gentoo, Fedora, Ubuntu), and Mac (OSX Panther, with a hacked install of Java 1.5) (more info for users)


The most recent installer version of the Installer allows you to download: (As of April 12, 2007)

  • FreeSpace 2
  • Windows:
    • FreeSpace Open 3.6.9 Final (regular and debug)
    • FRED2 Open 3.6.9 Final (regular and debug)
    • FreeSpace Open Launcher 5.5a
  • Macintosh:
    • FreeSpace Open 3.6.9 Final (regular and debug)
    • Soulstorm's OSX Launcher
  • The OpenAL Installer (NOTE: OpenAL must be installed to run FS2 Open)
  • 3.6.8 Zeta Media VP Files (optional, includes 710 patch)
  • 3.6.8 Zeta Advanced effects (only for those with high-end systems. Requires regular Media VP Files, includes 710 patch)
  • .OGG Cutscenes


Modifications available for Direct Download:

  • Derelict SCP Version (With optional voice)
  • Just Another Day 1 & 2 (separate options for each)
  • FreeSpace Port
  • Awakenings
  • Homesick
  • Transcend
  • Sync


Requirements and Notes

You can update your installation by simply running the Installer again. This will download any files that are out of date.

The Installer requires an internet connection to install.

  • It checks to see if your installation files are out of date via the web.
  • It automatically takes you to the download page of the most recent version, if your version is out of date.
Source: Original thread by Turey

Linux Specific Information

Pre-Compiled binaries for FS2 Open 3.6.9 Final are not currently available in the Installer.

You have two options:

  • Use Pre-Compiled binaries available here or here. (Check both locations for the most up to date binary)
  • Download the source from CVS. Follow the instruction in the article covering [Fs2 open on Linux|FS2 on Linux].

Manual Installation Guide

Linux Specific Information