Deprecation

From FreeSpace Wiki
(Redirected from Deprecated)
Jump to: navigation, search

When a feature or function is deprecated, this means that future versions will not support it. Although it may work in current or older versions of the software, the relevant code will not be updated, and it will eventually be deleted outright. Projects that rely on deprecated features or functions should find another way to accomplish the same effect.

Deprecated Features

  • DirectX API. The game now uses OpenGL.
  • AVI and MPG format support, both used through system player. Currently, the game has built-in support for original uncompressed MVE format clips and compressed Theora OGG ones.
  • It is no longer possible to use FreeSpace 1-style nebulae in FRED2. Setting up a nebula that way will crash the mission editor.
  • The -htl flag is no longer necessary ever since FreeSpace Open 3.6(?). In fact, now there's a -nohtl flag.
  • The -jpgtga flag is no longer necessary since FreeSpace Open 3.6.10. It's always on.
  • The -pcx32 flag is no longer present.
  • The -alpha_env flag is no longer necessary since FreeSpace Open 3.6.10. It's always on.
  • The -2d_poof flag is no longer necessary since FreeSpace Open 3.6.10. It's always on.
  • Smart shield recharging (-smart_shields flag) has been converted into an Ai_profiles.tbl feature. It is no longer controlled through a command line flag.
  • The -rlm flag is no longer necessary. It's always on.